[Libosinfo] [PATCH v2 1/3] install-scripts: Add get-supported-injection-media API
Zeeshan Ali (Khattak)
zeeshanak at gnome.org
Wed Feb 26 15:49:18 UTC 2014
On Wed, Feb 26, 2014 at 2:52 PM, Zeeshan Ali (Khattak)
<zeeshanak at gnome.org> wrote:
> On Wed, Feb 26, 2014 at 2:21 PM, Giuseppe Scrivano <gscrivan at redhat.com> wrote:
>> Signed-off-by: Giuseppe Scrivano <gscrivan at redhat.com>
>> ---
>> data/schemas/libosinfo.rng | 11 +++++++++++
>> osinfo/libosinfo.syms | 4 ++++
>> osinfo/osinfo_install_script.c | 16 +++++++++++++++-
>> osinfo/osinfo_install_script.h | 5 ++++-
>> osinfo/osinfo_loader.c | 16 ++++++++++++++--
>> 5 files changed, 48 insertions(+), 4 deletions(-)
>>
>> diff --git a/data/schemas/libosinfo.rng b/data/schemas/libosinfo.rng
>> index 0675217..a4fe2b7 100644
>> --- a/data/schemas/libosinfo.rng
>> +++ b/data/schemas/libosinfo.rng
>> @@ -616,6 +616,9 @@
>> <ref name='driver-signing-reqs'/>
>> </element>
>> </optional>
>> + <zeroOrMore>
>> + <ref name='supported-injection-media'/>
>
> In case of initrd, its not exactly a media so I'd call it
> 'supported-injection-method' or something such. Maybe in future we can
> also support 'network' method.
>
>> + </zeroOrMore>
>> <element name='template'>
>> <choice>
>> <group>
>> @@ -770,4 +773,12 @@
>> </data>
>> </element>
>> </define>
>> +
>> + <define name='supported-injection-media'>
>> + <element name='supported-injection-media'>
>> + <data type="string">
>> + <param name="pattern">initrd|web|cdrom</param>
>
> There is also the case of floppy, which is the only option for windows atm.
>
> That reminds me, you want to add this info to all existing install
> scripts. preferably in this series.
>
>> + * Returns: (transfer container)(element-type utf8): a list of supported media
>> + * for install script injection.
>
> * I'd provide a bit more description here.
> * This should be an enum, not strings on API level.
Actually perhaps even better if its exposed as a flags enum, which
would simplify the API a bit: app gets a simple type that they dont
need to free.
--
Regards,
Zeeshan Ali (Khattak)
FSF member#5124
More information about the Libosinfo
mailing list