[Libosinfo] [libosinfo PATCH 3/7] media: Improve on_location_read error message readability
Fabiano Fidêncio
fidencio at redhat.com
Thu Jun 27 12:56:09 UTC 2019
Let's add a ": " by the end of the error message, so the prefix doesn't
get concatenated with error message, increasing its readability.
Signed-off-by: Fabiano Fidêncio <fidencio at redhat.com>
---
osinfo/osinfo_media.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/osinfo/osinfo_media.c b/osinfo/osinfo_media.c
index 040584f..8cd4929 100644
--- a/osinfo/osinfo_media.c
+++ b/osinfo/osinfo_media.c
@@ -1301,7 +1301,7 @@ static void on_location_read(GObject *source,
stream = g_file_read_finish(G_FILE(source), res, &error);
if (error != NULL) {
- g_prefix_error(&error, _("Failed to open file"));
+ g_prefix_error(&error, _("Failed to open file: "));
g_task_return_error(data->res, error);
create_from_location_async_data_free(data);
--
2.21.0
More information about the Libosinfo
mailing list